Chicago, IL - 659 W. Randolph St.

Incident Report for Zentro

Resolved

Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 21, 2025 - 19:22 CDT

Identified

We have been made aware that the outage is due to a power issue in the area. ComEd ETA is 1:30 PM CDT
Posted Mar 21, 2025 - 12:26 CDT
This incident affected: Zentro Network (Zentro Internet).