OH-50 Public Square
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Jan 01, 2025 - 10:23 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 01, 2025 - 07:46 CST
Investigating
We’re aware of the service interruption at your property and are working to fix it as quickly as possible.
Posted Dec 31, 2024 - 08:46 CST