926 Maple Ave,
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jan 16, 2025 - 17:03 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 16, 2025 - 10:43 CST
This incident affected: Zentro Network (Zentro Internet).