Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted May 11, 2025 - 08:11 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 9 PM EST
Posted May 10, 2025 - 15:22 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue and continue to perform repairs. Estimated time to resolution is 3pm CST
Posted May 10, 2025 - 08:23 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 8:30 PM EST.
Posted May 09, 2025 - 17:18 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 4:30PM EST
Posted May 09, 2025 - 12:23 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted May 09, 2025 - 11:57 CDT
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 2:15 PM EST.
Posted May 09, 2025 - 10:13 CDT
This incident affected: Zentro Network (Zentro Internet).