Sugar Hill, GA - 1022 Level Creek Rd

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 03:07 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2025 - 23:47 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Mar 10, 2025 - 23:41 CDT
This incident affected: Zentro Network (Zentro Internet).