Planned maintenance has been completed. We appreciate your patience and understanding while we work to improve our services and continue to provide Enlightening Fast Internet.
Posted Sep 25, 2024 - 22:21 CDT
Investigating
A Planned Maintenance is scheduled service may be impacted during this time. We appreciate your patience and understanding while we work to improve our services and continue to provide Enlightening Fast Internet.
Posted Sep 25, 2024 - 10:56 CDT
This incident affected: Zentro Network (Zentro Internet).