Chicago, IL - 1140 N. LaSalle St.
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 02:16 CST
Investigating
An Emergency Maintenance was scheduled service may be impacted during this time. We appreciate your patience and understanding while we work to improve our services and continue to provide Enlightening Fast Internet.
Estimated ETR 2:13 AM CT.
Posted Nov 10, 2024 - 23:26 CST
This incident affected: Zentro Network (Zentro Internet).