Detroit Area

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. A planned maintenance is now undergoing, our estimated time of completion is no later than 6:00 AM EST. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Nov 13, 2025 - 21:33 CST

Identified

Customers in the Detroit area may be impacted by services outages in the region. Our technicians are on-site working to isolate and repair impacted components. At this time we are pending an estimated time of repair as we await further details from our technicians. Next updated to be provided by 11:00 PM EST. We appreciate your patience and understanding in the matter. To stay informed with the latest news please click 'Subscribe'.
Posted Nov 13, 2025 - 20:53 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Nov 13, 2025 - 18:51 CST
This incident affected: Zentro Network (Zentro Internet).