555 W. Kinzie St. & 365 N. Jefferson St. - Chicago, IL

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 03, 2025 - 18:59 CST

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 9:45pm.
Posted Mar 03, 2025 - 17:45 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Mar 03, 2025 - 17:43 CST