Atlantic House - 1163 West Peachtree St NE, Atlanta, Georgia

Incident Report for Zentro

Resolved

Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 07, 2025 - 11:34 CST

Identified

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 5:00 PM ET.
Posted Mar 06, 2025 - 14:15 CST