565 West Quincy Street, Chicago, IL

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 09:53 CDT

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 12:00 AM CST
Posted Apr 23, 2025 - 20:59 CDT
This incident affected: Zentro Network (Zentro Internet).