125 South Jefferson Street, Chicago, IL

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 23, 2025 - 17:19 CDT

Update

We are continuing to investigate this issue.
Posted Apr 23, 2025 - 14:49 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Apr 23, 2025 - 14:31 CDT
This incident affected: Zentro Network (Zentro Internet).