GA-1701D - Gainesville, GA - 1701 Dawsonville Hwy

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 22, 2025 - 13:54 CDT

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 5pm
Posted Mar 22, 2025 - 11:30 CDT

Investigating

We are currently investigating this issue.
Posted Mar 22, 2025 - 10:57 CDT