Detroit Michigan - 329 Holbrook Street
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Jan 05, 2025 - 13:14 CST
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 5pm EST
Posted Jan 05, 2025 - 12:12 CST
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 9am 01/06/25
Posted Jan 05, 2025 - 11:32 CST