Detroit, Michigan
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Sep 29, 2024 - 07:23 CDT
Update
We are continuing to investigate this issue.
Posted Sep 27, 2024 - 13:29 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Sep 27, 2024 - 13:29 CDT
This incident affected: Zentro Network (Zentro Internet).