Milwaukee, WI - 126 N. Jefferson St.
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 10:25 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 8:09AM.
Posted Sep 30, 2024 - 06:03 CDT
This incident affected: Zentro Network (Zentro Internet).