8150 Southwest 72nd Ave. Miami FL

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 01, 2025 - 17:54 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time for resolution.
Posted Apr 01, 2025 - 11:23 CDT

Identified

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 8:00 PM local time.
Posted Mar 31, 2025 - 16:39 CDT