Detroit, MI - 111 Cadillac Sq

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 02, 2025 - 11:49 CDT

Update

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 12:00 AM local time.
Posted Apr 01, 2025 - 19:07 CDT

Update

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 8:00 PM local time..
Posted Apr 01, 2025 - 16:47 CDT

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue.
Posted Apr 01, 2025 - 13:32 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Mar 31, 2025 - 13:56 CDT
This incident affected: Zentro Network (Zentro Internet).