100 Leslie Oaks Drive, Lithonia, GA

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jan 09, 2026 - 13:51 CST

Identified

We’ve identified the cause of the outage. Our fiber backbone was damaged by vandalism, leading to the current service disruption.

Our teams are working closely with our network partners to complete repairs, though the damage is extensive and restoration is taking longer than anticipated. Please know that this work is ongoing and remains a top priority.

We truly appreciate your patience and understanding.
Posted Jan 09, 2026 - 09:30 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Jan 09, 2026 - 03:58 CST
This incident affected: Zentro Network (Zentro Internet).