837 S. Wells
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Jan 01, 2025 - 07:47 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 31, 2024 - 08:42 CST
Investigating
We’re aware of the service interruption at your property and are working to fix it as quickly as possible.
Posted Dec 31, 2024 - 08:42 CST