Detroit, MI - 512 W Grand Blvd

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 03, 2025 - 12:08 CST

Update

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 3/3/2025 12:00 PM
Posted Mar 02, 2025 - 16:30 CST

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 3/2/2025 6:00 PM
Posted Mar 01, 2025 - 17:27 CST
This incident affected: Zentro Network (Zentro Internet).