4715 West Irving Park Road and 3953 West Dakin Street
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 22, 2024 - 17:53 CDT
Monitoring
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 22, 2024 - 10:30 CDT
Investigating
We are investigating reports of service interruptions at the locations.
Posted Sep 22, 2024 - 10:28 CDT
This incident affected: Zentro Network (Zentro Internet).