100 6th Street Northeast Atlanta, Georgia 30308
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Dec 30, 2024 - 13:15 CST
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by [12/29/2024, 7:00 PM CST]
Posted Dec 29, 2024 - 13:44 CST
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by [12/29/2024, 3:00 PM CST].
Posted Dec 29, 2024 - 13:08 CST