Sands at Saint Lucie - 2750 South US Highway 1, Fort Pierce, Florida 34982
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jan 27, 2025 - 17:04 CST
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 8:00 PM.
Posted Jan 27, 2025 - 16:41 CST