Chicago, IL - 5415 North Sheridan Rd. | 5701 N. Sheridan Rd. | 5001 N. Ashland Ave. | 1022 W. Catalpa Ave. | 5100 N. Marine Dr. | 4720 N. Racine Avenue | 5958 N. Kenmore Ave. | 5330 Kenmore Ave. | 5423 N. Winthrop Ave.| 5510 N. Kenmore Ave.

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Nov 13, 2025 - 15:15 CST

Identified

We have been notified of a power outage in your area impacting networking components. Local Power Utility has an estimated time for resolution by 2:30 PM CST. To stay up to date with the latest news, please click 'Subscribe'.
Posted Nov 13, 2025 - 13:16 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Nov 13, 2025 - 12:55 CST
This incident affected: Zentro Network (Zentro Internet).