OH-2021W41 - 2021 West 41st Street, Cleveland, OH

Incident Report for Zentro

Resolved

Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 17, 2025 - 10:24 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has removed any estimations at this time and we await further information
Posted Mar 16, 2025 - 15:51 CDT

Investigating

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 3/16/2025, 5:00 PM CDT
Posted Mar 16, 2025 - 11:31 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2025 - 11:30 CDT

Identified

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 3/16/2025, 5:00 PM CDT
Posted Mar 16, 2025 - 11:28 CDT