Cleveland, OH - 55 Public Sq
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 11, 2024 - 11:47 CST
Investigating
We are investigating reports of service interruptions at the location.
Posted Dec 11, 2024 - 10:56 CST
This incident affected: Zentro Network (Zentro Internet).