Blacklick, OH - 8352 E Broad St
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 29, 2024 - 14:01 CDT
Monitoring
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 29, 2024 - 13:58 CDT
Update
Customers may be experiencing service interruptions. Technicians have been dispatched to address the issue. Estimated time to resolution is 2 P.M. EST
Posted Sep 29, 2024 - 08:40 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 11:52 A.M.
Posted Sep 29, 2024 - 07:54 CDT
Identified
We have been notified of a power outage in your area. Local Power Utility has no provided estimated time for resolution at this time
Posted Sep 28, 2024 - 09:57 CDT
Investigating
Reports of local power have been verified to have been restored, we are awaiting access to dispatch a technician
Posted Sep 27, 2024 - 18:48 CDT
This incident affected: Zentro Network (Zentro Internet).