Detroit, MI - 735 Griswold St

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jun 10, 2025 - 08:29 CDT

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is by the end of the day 6/10/25.
Posted Jun 09, 2025 - 17:52 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Jun 09, 2025 - 09:53 CDT
This incident affected: Zentro Network (Zentro Internet).