Chicago, IL - 51 E. 14th St.
Incident Report for Zentro Internet
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 13, 2024 - 10:11 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 13, 2024 - 10:10 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 8:43 AM.
Posted Sep 13, 2024 - 06:58 CDT
This incident affected: Zentro Network (Zentro Internet).