Long Beach, CA - 230 West 3rd Street

Incident Report for Zentro

Update

Customers may be experiencing intermittent connectivity. Additional maintenance is required to restore service and is being addressed by our team. The next update will be provided by 12:00 P.M. PST tomorrow, 12/15. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue. Please click "Subscribe" to be informed of the latest updates.
Posted Dec 14, 2025 - 13:57 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Dec 12, 2025 - 19:41 CST
This incident affects: Zentro Network (Zentro Internet).