MyPortal.ZentroInternet.com Outage

Incident Report for Zentro

Resolved

The affected website is back online. If you are still experiencing trouble connecting to the website, please call (877) ZENTRO - 1.
Posted Apr 28, 2025 - 10:41 CDT

Identified

Customer Portal is currently experiencing an outage. Our team is working on restoring service.
Posted Apr 28, 2025 - 10:21 CDT
This incident affected: Zentro Websites (Zentro Customer Portal).