Detroit, MI - 111 Cadillac Square

Incident Report for Zentro

Identified

Customers may be experiencing intermittent connectivity. Our technicians have been dispatched and have identified the issue as a fiber cut caused by construction in the area. We have engaged our service partners to repair the cut and will provide additional updates by 8PM Eastern.
Posted Sep 18, 2025 - 12:38 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Sep 17, 2025 - 16:26 CDT
This incident affects: Zentro Network (Zentro Internet).