Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Nov 22, 2024 - 10:15 CST
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 2 A.M CST
Posted Nov 21, 2024 - 22:02 CST
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 9:30 PM CST.
Posted Nov 21, 2024 - 20:26 CST
Update
We have been notified of a power outage in your area. Local Power Utility is pending an updated estimated time of repair.
Posted Nov 21, 2024 - 19:48 CST
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 7:45 PM CST.
Posted Nov 21, 2024 - 18:18 CST
Investigating
We are investigating reports of service interruptions at the location.
Posted Nov 21, 2024 - 17:56 CST
This incident affected: Zentro Network (Zentro Internet).