Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 25, 2024 - 22:20 CDT
Monitoring
Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 25, 2024 - 11:26 CDT
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 11pm.
Posted Sep 24, 2024 - 13:04 CDT
This incident affected: Zentro Network (Zentro Internet).