Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Aug 01, 2025 - 15:44 CDT
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 11:00 PM.
Posted Aug 01, 2025 - 10:42 CDT
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 8/1 @ 10:00AM CDT
Posted Aug 01, 2025 - 04:17 CDT
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 9:00 PM.
Posted Jul 31, 2025 - 18:47 CDT
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 7:00 PM.
Posted Jul 31, 2025 - 18:40 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Jul 31, 2025 - 11:16 CDT
This incident affected: Zentro Network (Zentro Internet).