Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 14, 2024 - 11:55 CDT
Update
Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 14, 2024 - 10:21 CDT
Update
Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 14, 2024 - 10:16 CDT
Monitoring
Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 11, 2024 - 12:08 CDT
Identified
We have been notified of a power outage in your area. Fort Pierce Utilities Authority has not provided an estimated time of repair.