Middletown, OH - 2691 & 2693 Towne Boulevard

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 05, 2025 - 11:02 CST

Update

Customers may continue to experience service disruptions. Our team is working diligently to restore services, our current estimated time of resolution is 12/5/2025 at 6:00 PM EST. We apologize for delays and appreciate your patience and understanding in the matter. Our next update will be provided no later than 12:00 PM CST. To stay informed, please click 'Subscribe'
Posted Dec 04, 2025 - 15:23 CST

Identified

Customers may continue to experience service interruptions. Our team will be onsite tomorrow 12/4 due to inclement weather conditions. We apologize for delays and appreciate your patience and understanding in the matter. Our next update will be provided no later than 12:00 PM CST. To stay informed, please click 'Subscribe'
Posted Dec 03, 2025 - 20:40 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Dec 02, 2025 - 16:24 CST
This incident affected: Zentro Network (Zentro Internet).