3444 2nd Avenue, Detroit, MI

Incident Report for Zentro

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 5:00 PM local time.
Posted Nov 07, 2025 - 10:11 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Nov 06, 2025 - 13:11 CST
This incident affects: Zentro Network (Zentro Internet).