Chicago, IL - 2412 S Michigan Ave

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Jan 02, 2026 - 14:32 CST

Investigating

We are currently investigating this issue.
Posted Jan 02, 2026 - 09:51 CST