Alexander at Stonecrest

Incident Report for Zentro

Resolved

Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 29, 2024 - 07:18 CDT

Identified

Customers may be experiencing intermittent connectivity due to current extreme weather conditions.
Posted Sep 27, 2024 - 06:23 CDT
This incident affected: Zentro Network (Zentro Internet).