Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 08, 2025 - 10:03 CDT
Update
Customers may be experiencing intermittent connectivity. We have identified damage to a fiber cable caused by a construction crew outside of 111 Cadillac. Technicians have been dispatched to address the issue. The estimated time of repair is 10:00 PM.
Posted Apr 07, 2025 - 16:21 CDT
Update
Customers may be experiencing intermittent connectivity. We have identified damage to a fiber cable caused by a construction crew outside of 111 Cadillac. Technicians have been dispatched to address the issue. Once the extent of the damage has been assessed, we will update with an estimated time for repair.
Posted Apr 07, 2025 - 15:12 CDT
Identified
Customers may be experiencing intermittent connectivity. We have identified damage to a fiber cable caused by a construction crew outside of 111 Cadillac. Technicians have been dispatched to address the issue. Once the extent of the damage has been assessed, we will update with an estimated time for repair.
Posted Apr 07, 2025 - 13:13 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Apr 07, 2025 - 10:30 CDT
This incident affected: Zentro Network (Zentro Internet).