Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 01, 2025 - 17:05 CST
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 6:00 PM EST
Posted Mar 01, 2025 - 15:24 CST
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 4pm
Posted Mar 01, 2025 - 13:30 CST
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 1pm.
Posted Mar 01, 2025 - 09:08 CST
Investigating
We are investigating reports of service interruptions at the location.
Posted Feb 28, 2025 - 20:37 CST
This incident affected: Zentro Network (Zentro Internet).