Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 15, 2025 - 15:32 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Repairs are ongoing and are expected to be completed by the end of day 4/15/25.
Posted Apr 15, 2025 - 10:35 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Due to hazardous conditions with downed powerlines, repair efforts have been delayed until conditions are made safe.
Posted Apr 14, 2025 - 17:05 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is TBD.
Posted Apr 14, 2025 - 10:05 CDT
This incident affected: Zentro Network (Zentro Internet).