Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 20, 2024 - 08:53 CDT
Identified
Customers may be experiencing service interruptions. Technicians have been dispatched to address the issue. Estimated time to resolution is 12:30 P.M.
Posted Sep 20, 2024 - 08:34 CDT
This incident affected: Zentro Network (Zentro Internet).