Southeast
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 10:26 CDT
Identified
Valued Customers in the Southeast,

We understand that Hurricane Helene is causing significant challenges, including intermittent power and internet service disruptions in some areas. Our thoughts are with you during this difficult time. We are committed to providing you with the support you need and are working diligently to restore service as quickly as possible.

For the most up-to-date information on service status and assistance, please see below.

Thank you for your patience and understanding.
Posted Sep 27, 2024 - 07:54 CDT
This incident affected: Zentro Network (Zentro Internet).