Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 03, 2025 - 16:28 CDT
Update
Some customers may be experiencing intermittent connectivity issues. Our team is actively working to resolve the problem, our updated estimated time of repair set for 3:00 PM CST. To receive real-time updates, please click ‘Subscribe’. We appreciate your patience and understanding.
Posted Oct 03, 2025 - 12:04 CDT
Identified
Some customers may be experiencing intermittent connectivity issues. Our team is actively working to resolve the problem, with an estimated time of repair set for 12:00 PM on October 3rd.To receive real-time updates, please click ‘Subscribe’. We appreciate your patience and understanding.
Posted Oct 02, 2025 - 20:55 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Oct 02, 2025 - 19:39 CDT
This incident affected: Zentro Network (Zentro Internet).