Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 25, 2025 - 10:03 CDT
Update
Customers may be experiencing intermittent connectivity. Our onsite team has located fiber damage, Fiber repair and splicing are currently underway. Due to the nature of the repairs needed, we are unable to provide a time to resolution at this moment. Please click Subscribe to stay up to date with our latest updates
Posted Apr 24, 2025 - 18:11 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is TBD.
Posted Apr 24, 2025 - 13:38 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Apr 24, 2025 - 11:17 CDT
This incident affected: Zentro Network (Zentro Internet).