Portland, OR - 4830 Northwest 162nd Terrace, 15971, 15959, 15978, and 16154 Northwest Hidalgo Lane

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 10, 2025 - 17:04 CST

Identified

Customers may be experiencing intermittent connectivity. Technicians were dispatched to address the issue. Additional maintenance is required to restore service and is being addressed by our team. The next update will be provided by 12:00 P.M. PST tomorrow, 12/11. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue. Please click "Subscribe" to be informed of the latest updates.
Posted Dec 10, 2025 - 15:07 CST

Update

Customers may be experiencing intermittent connectivity. Technicians were dispatched to address the issue. Additional maintenance is required to restore service and is being addressed by our team. The next update will be provided by 12:00 P.M. PST tomorrow, 12/10. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue. Please click "Subscribe" to be informed of the latest updates.
Posted Dec 09, 2025 - 15:33 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Dec 09, 2025 - 11:16 CST
This incident affected: Zentro Network (Zentro Internet).