Richmond, VA - 202 North 20th Street

Incident Report for Zentro

Update

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is to be determined.
Posted Jan 26, 2026 - 10:02 CST

Identified

We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time for resolution.
Posted Jan 26, 2026 - 07:02 CST
This incident affects: Zentro Network (Zentro Internet).